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Introduction
Overview
Password Keeper for Windows 95/NT is a small freeware utility for storing your frequently used passwords. 
Password information can be stored, editing and printed with this easy to use program. 

Each password file that you create can contain up to 500 account entries. You'll never forget a password again 
with this handy utility installed on your Windows 95/NT system.

Password Keeper data files are stored in an encrypted format to prevent unauthorized users from accessing and 
viewing them. Passwords can be copied to the Clipboard and pasted into other login programs.

Desktop Locations
Password Keeper’s location on the desktop is saved when the program is exited. Whenever you start Password 
Keeper it will reappear on the desktop where you last placed it. Password Keeper dialog box locations are also 
stored and reused the next time they are opened.

Taskbar Tray
Password Keeper for Windows 95/NT can be optionally configured to place it’s program icon in the Taskbar Icon 
Notification Tray. This option provides a simple means of keeping the taskbar button region clear for other running
programs.



Installing Password Keeper
Installation
To install Password Keeper for Windows 95/NT on your computer simply create a new, empty folder and place 
the files; PASSKEEP.EXE and PASSKEEP.HLP there.

PASSKEEP.EXE - The Password Keeper Application
PASSKEEP.HLP - The Windows 95/NT Help File

Note: If you have an earlier version of Password Keeper for Windows 95/NT installed on your computer, simply 
replace the PASSKEEP.EXE and PASSKEEP.HLP files with the newer versions. Password Keeper will still use 
the settings found in your previous PASSKEEP.INI configuration file.

Note: The file PASSKEEP.INI will be created after Password Keeper is run for the first time. This file will contain 
the various application settings specified in the Password Keeper Options dialog box as well as the main 
window’s size and location on the desktop.

Note: Some earlier versions of Password Keeper for Windows 95/NT included a PASSKEEP.WRI documentation 
file. This file has been replaced by the PASSKEEP.HLP file and can now be deleted.

Warning: If you rename the PASSKEEP.EXE file you must also rename the HLP and INI files using the same 
basename. For example if you change the Password Keeper application file name to NewName.exe, rename the 
help and configurations files to NewName.hlp and NewName.ini respectively. The HLP and INI files must reside in
the same folder as the Password Keeper application file itself.



Configuring Password Keeper
Password Keeper Options
Select the File | Options menu item to display the Password Keeper Options dialog box. This window will allow 
you to change the various Password Keeper program settings listed below.

Time Period to Display Account Password
Specify the time period to display account password information before hiding the selected entry again.

Always Show Information
Check this item to show the selected account password indefinitely, instead of hiding it after a short display 
period.

Show Tool Bar Tips
Check this item to display small popup tip windows when the mouse pointer is placed over toolbar ribbon 
pushbuttons. A short description of the button currently beneath the mouse will be shown when this item is 
checked.

Place Icon in the Taskbar Tray
Check this item to display a small Password Keeper program icon in the Taskbar Icon Notification Tray. If this 
item is selected and the Password Keeper window is minimized a button will not be added to the Taskbar, to 
restore the Password Keeper window on the desktop press the small icon in the taskbar tray instead. This 
option is available to keep the taskbar free for other running programs.

Dark Window Backgrounds
Check this item to display the text in list windows with a dark background instead of the paper white 
background MS Windows normally uses when displaying text.

Reopen the Last File Used at Startup
Check this box to reopen the last password file used when Password Keeper is launched.

Save Changes Automatically
Check this box to automatically save editing changes when a password document is closed. If this box is not 
checked you will be prompted before closing documents that have changed.

Sounds with Warning Dialog Boxes
Check this box to play a short beep sound when Password Keeper displays a warning dialog box or an error 
occurs.

OK
Press this button when you have completed your selection of Password Keeper program options. When you 
press this button the Password Keeper Options dialog box will be closed and your settings will be saved.

Cancel
Press this button to close the Password Keeper Options dialog box without making any changes. If you have 
made any changes to the option settings, and then press this button your changes will not be used, and your 
previous settings will remain in use.

Note: The options you have selected will be saved when you press the OK button. The desktop location of the 
Password Keeper Options window itself will also be stored. Your settings will be saved in the PASSKEEP.INI file 
in the same folder that the Password Keeper application is located in.



Password Keeper Menus
Menu Commands
The Password Keeper window displays a set of menus used to select various Password Keeper operations. All of
wShell’s commands are carried out using items listed on these menus. To display the commands available click 
your mouse on the desired menu title. A drop down list will be displayed, allowing you to select the command you 
wish to carry out.

 The File Menu
 The Edit Menu
 The View Menu
 The Help Menu

Tip: Most commonly used menu commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



File Menu
File Menu Commands
The File menu provides commands to work with the document files used by Password Keeper. A short description
of each item follows:

New
Creates a new Password Keeper document. You will be prompted to assign a document access password to 
the file you are creating. The Ctrl+N shortcut can be used for this command.

Open
Opens an existing Password Keeper document, and loads it for editing or viewing. When this item is selected
the standard MS Windows Explorer file browser will be displayed, use this window to select the document 
you wish to work with. Check the Open as Read-Only box to load documents for viewing only. You will be 
prompted to enter the document access password for the file you select. This is the password you assigned 
to the file when it was created. The Ctrl+O shortcut can be used for this command.

Properties
Displays a small window showing file properties for the currently selected Password Keeper document. This 
window will display the document’s file name, folder location, size, last modification date and file access 
permissions. The Alt+Enter shortcut can be used for this command.

Close
Closes the currently active document. If the document has been edited you will be prompted to save or 
discard the changes before closing. The Ctrl+W shortcut can be used for this command.

Save
Saves changes made to the currently selected document. This menu will be disabled (grayed) if no changes 
have been made to the document since it was last loaded or saved. The Ctrl+S shortcut can be used for this 
command.

Save As
Saves the currently active document with a new name. When this item is selected the standard MS Windows
Explorer file browser will be displayed, use this window to specify a new name for the document. You will be 
prompted to assign a new password and verify it before the file is saved with the new name and access 
password you have selected.

Print
Prints the currently selected Password Keeper document on your system’s printer. A dialog box will appear 
before printing is started to allow you to select the printer to be used and various other printer options. The 
Ctrl+P shortcut can be used for this command.

Printer Font
Displays a font selection dialog box. The font style and size selected will be used when printing password 
account information.

File Password
This command allows you to change the document access password for the file currently being edited. You 
will be prompted to enter the current document access password assigned to the file as well as the new 
password you wish to assign to it. You will be required to type the new password assignment a second time 
to verify the entry. This item will be disabled (grayed) if the current file has been modified and not saved yet, 
or the file was opened for viewing as read-only.

Options
Opens the Password Keeper Options dialog box and allows you to change Password Keeper program 
settings. Use this command to configure the Password Keeper program.

Exit
Closes the Password Keeper program and returns control to the Explorer desktop. The Ctrl+Q shortcut can 
be used for this command.



Tip: Commonly used File commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



Edit Menu
Edit Menu Commands
The Edit menu provides commands used to edit the contents of Password Keeper documents. A short description
of each item follows:

Copy Password
Copies the current account selection’s password to the Clipboard. You can then paste this information into 
your login program. The Ctrl+C shortcut can be used for this command.

Add Account
Use this command to add a new password account record to the current document. The Ctrl+A shortcut can 
be used for this command.

Edit Account
Use this command to edit the currently selected password account record. You will be able to change the 
account name, login ID, password and notes specific to the currently selected record. The Ctrl+E shortcut 
can be used for this command.

Delete
Deletes the currently selected account record. You will be prompted to confirm the record you wish to delete. 
The Del shortcut can be used for this command.

Read Only
Turns editing permission on and off. If this item is checked the current document can be viewed but editing 
will not be allowed.

Tip: Commonly used Edit commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



View Menu
View Menu Commands
The View menu provides commands used to change Password Keeper display options. These items provide a 
means of changing the Password Keeper window appearance. A short description of each item follows:

By Account
Check this item to display password account records sorted by account name.

By User Name
Check this item to display password account records sorted by user name.

By Password
Check this item to display password account records sorted by password.

Minimize
Minimizes the Password Keeper window to a button or icon on the taskbar. The Ctrl+Y shortcut can be used 
for this command.

Always on Top
Use this command to keep the Password Keeper window top most on the desktop. When this item is 
checked the Password Keeper window will float above all other non-topmost windows on the desktop. This 
item is useful if you normally run Password Keeper with a small window that would be easily obscured by 
other applications.



Help Menu
Help Menu Commands
The Help menu provides commands used to get help with Password Keeper operations. A short description of 
each item follows:

Contents
Opens the Password Keeper Help window and displays the Table of Contents. The F1 shortcut can be used 
for this command.

Search
Opens Password Keeper Help and displays the Search window. You can use this window to search for 
specific Password Keeper help topics.

How to Use Help
Opens a Help window that explains how to use the MS Windows 95/NT Help program.

About Password Keeper
Displays the Password Keeper splash box. This window contains program information, the current version of 
Password Keeper you are running and a program copyright notice. Click the mouse anywhere in this window 
to close it

Tip: Commonly used Help commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



Toolbar Buttons
Tool Ribbon Buttons
Most commonly used Password Keeper menu commands can also be quickly invoked by pressing a button on 
the toolbar ribbon displayed at the top of the main window. These buttons work exactly the same way as the 
corresponding menu items that they duplicate.

New - Create a new document

Open - Open an existing document

Save - Save changes made to a document

Print - Print the current document

Properties - Show document properties

Copy - Copy the password entry

Add - Add a new account record

Edit - Edit the current account record

Delete  - Delete the current account record

Options - Open the Password Keeper Options dialog

Help - Open this Help file

About - Show Password Keeper splash box

Tip: If the Show ToolBar Tips option is selected a small popup tip window will appear when the mouse pointer is 
placed over a button. A short description of what each button does can be viewed using this method.



Shortcut Keys
Shortcuts
Shortcut keys allow you to quickly invoke Password Keeper menu commands without first displaying the menu 
and then selecting an item from it. The most commonly used Password Keeper commands can be invoked using 
the following shortcut keys.

Ctrl+A Add a new password account record
Ctrl+C Copy the password to the Clipboard
Ctrl+E Edit the current account record
Ctrl+N Create a new Document
Ctrl+O Open an existing document
Ctrl+P Print the current document
Ctrl+Q Exit Password Keeper, and return to the desktop
Ctrl+S Save changes made to the document
Ctrl+W Close the current document
Ctrl+Y Minimize Password Keeper to a button or icon

Del Delete the current selection
Alt+Enter Show properties for current document
F1 Display this Help file



Comments and Upgrades
Comments and Suggestions
If you have comments, questions or find any bugs in Password Keeper for Windows 95/NT please feel free to 
contact me on CompuServe or America Online.

Upgrade Notification
If you would like to be notified when this application is upgraded send me an email message with your online 
address. Please include the version number of Password Keeper that you are using and the location that you 
downloaded my software from.    I will email you when a new version of Password Keeper for Windows 95/NT is 
uploaded to my web site on the Internet, CompuServe, America Online, ExecPC, ZD Net, and MSN.

Gregory Braun
CompuServe: 71613,2175
AOL: GreggBraun
Email: 71613.2175@compuserve.com
Web Site: http://www.execpc.com/~sbd
Phone: 1.414.444.8497

Contributions
While Password Keeper is offered as Freeware, if you would like to pay for it you are welcome to send any 
amount you wish to:

Gregory Braun
5609 West Hadley Street
Milwaukee, WI 53210-1554    USA

Your contributions are always welcome, and encourage me to continue developing new applications.

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)



Release History
Password Keeper for Windows 95/NT Release History

v2.0 Original in-house development and testing of MS Windows 95/NT conversion using the Microsoft Win32 
SDK.

v2.1 Added 95/NT splash box for release.

v2.2 Added options to place program icon in the taskbar notification tray, and to save desktop locations for all 
dialog boxes. Increased the encryption rotor sizes.

v2.3 Added an option to automatically save the changes made to a password document.

v2.4 Added Login Name entry field to account password records.

v2.5 Fixed several minor bugs.

v2.6 Added support for screen color settings as specified in the Display Properties dialog. Added default user 
and company name to the splash box.

v2.7 Added an option to change document access passwords. Included a new MS Windows 95/NT Help file. 

Last Update: March 9th, 1997

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)



Software by Design Web Site
Software by Design
You can download the latest versions of all of my freeware from my web site on the internet. I post the latest 
releases of my software there first. Click your mouse on the link listed below to visit the Software by Design web 
site.

Software by Design Web Site

(http://www.execpc.com/~sbd)

Freeware Titles
The following software titles are available at my web site on the Internet and can also be found on CompuServe, 
America Online, ExecPC, MSN and ZD Net.

NoteBook for Windows (NBOOK.ZIP)
NoteBook for Windows 95/NT (NBOOK32.ZIP)
Reminders for Windows (REMIND.ZIP)
Reminders for Windows 95/NT (REMIND32.ZIP)
ToolBar for Windows (TBAR.ZIP)
ToolBar for Windows 95/NT (TBAR32.ZIP)
Screen Loupe for Windows (LOUPE.ZIP)
Screen Loupe for Windows 95/NT (LOUPE32.ZIP)
Screen Loupe for Macintosh (LOUPE.SEA)
Audition for Windows 95/NT (AUDITION.ZIP)
Password Keeper for Windows 95/NT (PASSKEEP.ZIP)
CardBase for Windows 95/NT (CARDBASE.ZIP)
File Editor for Windows (FXEDIT.ZIP)
File Editor for Windows 95/NT (FXEDIT32.ZIP)
Crypto for Windows 95/NT (CRYPTO.ZIP)
Icon Extractor for Windows (ICONX.ZIP)
Icon Extractor for Windows 95/NT (ICONX32.ZIP)
TxEdit for Windows 95/NT (TXEDIT.ZIP)
DLL Show for Windows 95 (DLLSHOW.ZIP)
RGB Editor for Windows (RGB.ZIP)
RGB Editor for Windows 95/NT (RGB32.ZIP)
FontShow for Windows 95/NT (FONTSHOW.ZIP)
Programmer's IDE (PMAN.ZIP)
Programmer's IDE 95/NT (PMAN32.ZIP)
Touch for Windows (WTOUCH.ZIP)
Disk CleanUp for Windows 95/NT (CLEANUP.ZIP)
BattleStar for Windows (BSTAR.ZIP)
BattleStar for Windows 95/NT (BSTAR32.ZIP)
World Radio for Macintosh (WRADIO.SEA)

Note: The latest versions of my software programs are always posted on my web site first. Versions found on the 
other online services may be earlier releases.



BBS and Internet Operators
Webmasters
Please upload the original ZIP file intact and title the submission:

"Password Keeper for Windows 95/NT v2.7"
--Author Gregory Braun

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)

Note: This site also supports anonymous FTP transfers.






